Fedora 13 : python-paste-1.7.4-1.fc13 (2010-10414)

Medium Nessus Plugin ID 47229


The remote Fedora host is missing a security update.


***1.7.4*** * The only real change is to paste.httpexceptions, which was using insecure quoting of some parameters and allowed an XSS hole, most specifically with its 404 messages. The most notably WSGI application using this is paste.urlparse.StaticURLParser and PkgResourcesParser. By directing someone to an appropriately formed URL an attacker can execute arbitrary JavaScript on the victim's client. paste.urlmap.URLMap is also affected, but only if you have no application attached to /. Other applications using paste.httpexceptions may be effected (especially HTTPNotFound).
WebOb/webob.exc.HTTPNotFound is not affected. ***1.7.3*** * Fix paste.httpserver on Python 2.6. * Fix paste.auth.cookie, which would insert newlines for long cookies. * paste.util.mimeparse parses a single * in Accept headers (sent by IE 6). * Fix some problems with the wdg_validate middleware.

- Improvements to paste.auth.auth_tkt: add httponly support, don't always aggressively set cookies without the wildcard_cookie option. Also on logout, make cookies expire. * In paste.proxy.Proxy handle Content-Length of
-1. * In paste.httpexceptions avoid some unicode errors.
* In paste.httpserver handle .read() from 100 Continue properly (because of a typo it was doing a readline).

- Update paste.util.mimeparse from upstream.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected python-paste package.

See Also



Plugin Details

Severity: Medium

ID: 47229

File Name: fedora_2010-10414.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2010/07/01

Modified: 2016/05/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:python-paste, cpe:/o:fedoraproject:fedora:13

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/06/25

Reference Information

BID: 41160

FEDORA: 2010-10414