Fedora 11 : gif2png-2.5.1-1102.fc11 (2010-0330)

High Nessus Plugin ID 47180


The remote Fedora host is missing a security update.


- Tue Jan 5 2010 Enrico Scholz <enrico.scholz at informatik.tu-chemnitz.de> - 2.5.1-1102

- catch another possible overflow when appending a numbered suffix (detected to Tomas Hoger)

- applied the -overflow patch...

- Sat Jan 2 2010 Enrico Scholz <enrico.scholz at informatik.tu-chemnitz.de> - 2.5.1-1101

- changed -overflow patch to abort on bad filenames instead of processing truncated ones

- Fri Jan 1 2010 Enrico Scholz <enrico.scholz at informatik.tu-chemnitz.de> - 2.5.1-1100

- fixed command line buffer overflow (#547515)

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected gif2png package.

See Also



Plugin Details

Severity: High

ID: 47180

File Name: fedora_2010-0330.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2010/07/01

Modified: 2015/10/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:gif2png, cpe:/o:fedoraproject:fedora:11

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2010/01/08

Reference Information

FEDORA: 2010-0330