Debian DSA-2064-1 : xulrunner - several vulnerabilities

high Nessus Plugin ID 47153

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Several remote vulnerabilities have been discovered in Xulrunner, a runtime environment for XUL applications. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2010-0183 'wushi' discovered that incorrect pointer handling in the frame processing code could lead to the execution of arbitrary code.

- CVE-2010-1196 'Nils' discovered that an integer overflow in DOM node parsing could lead to the execution of arbitrary code.

- CVE-2010-1197 Ilja von Sprundel discovered that incorrect parsing of Content-Disposition headers could lead to cross-site scripting.

- CVE-2010-1198 Microsoft engineers discovered that incorrect memory handling in the interaction of browser plugins could lead to the execution of arbitrary code.

- CVE-2010-1199 Martin Barbella discovered that an integer overflow in XSLT node parsing could lead to the execution of arbitrary code.

- CVE-2010-1200 Olli Pettay, Martijn Wargers, Justin Lebar, Jesse Ruderman, Ben Turner, Jonathan Kew and David Humphrey discovered crashes in the layout engine, which might allow the execution of arbitrary code.

- CVE-2010-1201 'boardraider' and 'stedenon' discovered crashes in the layout engine, which might allow the execution of arbitrary code.

- CVE-2010-1202 Bob Clary, Igor Bukanov, Gary Kwong and Andreas Gal discovered crashes in the JavaScript engine, which might allow the execution of arbitrary code.

Solution

Upgrade the xulrunner packages.

For the stable distribution (lenny), these problems have been fixed in version 1.9.0.19-2.

See Also

https://security-tracker.debian.org/tracker/CVE-2010-0183

https://security-tracker.debian.org/tracker/CVE-2010-1196

https://security-tracker.debian.org/tracker/CVE-2010-1197

https://security-tracker.debian.org/tracker/CVE-2010-1198

https://security-tracker.debian.org/tracker/CVE-2010-1199

https://security-tracker.debian.org/tracker/CVE-2010-1200

https://security-tracker.debian.org/tracker/CVE-2010-1201

https://security-tracker.debian.org/tracker/CVE-2010-1202

https://www.debian.org/security/2010/dsa-2064

Plugin Details

Severity: High

ID: 47153

File Name: debian_DSA-2064.nasl

Version: 1.16

Type: local

Agent: unix

Published: 6/29/2010

Updated: 1/4/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:xulrunner, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/27/2010

Reference Information

CVE: CVE-2010-0183, CVE-2010-1196, CVE-2010-1197, CVE-2010-1198, CVE-2010-1199, CVE-2010-1200, CVE-2010-1201, CVE-2010-1202

BID: 41082, 41087, 41090, 41093, 41094, 41100, 41102, 41103

DSA: 2064