Apache Tomcat 4.x < 4.1.37 Multiple Vulnerabilities

Medium Nessus Plugin ID 47030

Synopsis

The remote Apache Tomcat server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the instance of Apache Tomcat 4.x listening on the remote host is prior to 4.1.37. It is, therefore, affected by the following vulnerabilities :

- The remote Apache Tomcat install may be vulnerable to an information disclosure attack if the deprecated AJP connector processes a client request having a non-zero Content-Length and the client disconnects before sending the request body. (CVE-2005-3164)

- The remote Apache Tomcat install may be vulnerable to a cross-site scripting attack if the JSP and Servlet examples are enabled. Several of these examples do not properly validate user input.
(CVE-2007-1355, CVE-2007-2449)

- The remote Apache Tomcat install may be vulnerable to a cross-site scripting attack if the Manager web application is enabled as it fails to escape input data. (CVE-2007-2450)

- The remote Apache Tomcat install may be vulnerable to an information disclosure attack via cookies. Apache Tomcat treats the single quote character in a cookie as a delimiter which can lead to information, such as session ID, to be disclosed. (CVE-2007-3382)

- The remote Apache Tomcat install may be vulnerable to a cross-site scripting attack if the SendMailServlet is enabled. The SendMailServlet is a part of the examples web application and, when reporting error messages, fails to escape user provided data. (CVE-2007-3383)

- The remote Apache Tomcat install may be vulnerable to an information disclosure attack via cookies. The previous fix for CVE-2007-3385 was incomplete and did not account for the use of quotes or '%5C' in cookie values.
(CVE-2007-3385, CVE-2007-5333)

- The remote Apache Tomcat install may be vulnerable to an information disclosure attack via the WebDAV servlet.
Certain WebDAV requests, containing an entity with a SYSTEM tag, can result in the disclosure of arbitrary file contents. (CVE-2007-5461)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number..

Solution

Upgrade to Apache Tomcat version 4.1.37 or later.

See Also

http://tomcat.apache.org/security-4.html#Fixed_in_Apache_Tomcat_4.1.37

https://www.securityfocus.com/archive/1/archive/1/469067/100/0/threaded

https://www.securityfocus.com/archive/1/archive/1/471351/100/0/threaded

https://www.securityfocus.com/archive/1/archive/1/471357/100/0/threaded

https://www.securityfocus.com/archive/1/archive/1/476442/100/0/threaded

https://www.securityfocus.com/archive/1/archive/1/474413/100/0/threaded

https://www.securityfocus.com/archive/1/archive/1/476444/100/0/threaded

https://www.securityfocus.com/archive/1/archive/1/487822/100/0/threaded

https://www.securityfocus.com/archive/1/archive/1/507985/100/0/threaded

Plugin Details

Severity: Medium

ID: 47030

File Name: tomcat_4_1_37.nasl

Version: 1.17

Type: remote

Family: Web Servers

Published: 2010/06/16

Updated: 2018/11/15

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/02/09

Vulnerability Publication Date: 2005/09/30

Reference Information

CVE: CVE-2005-3164, CVE-2007-1355, CVE-2007-2449, CVE-2007-2450, CVE-2007-3382, CVE-2007-3383, CVE-2007-3385, CVE-2007-5333, CVE-2007-5461

BID: 15003, 24058, 24475, 24476, 24999, 25316, 26070, 27706

Secunia: 25678, 26466, 28878, 27398

CWE: 22, 79, 200