Apache Tomcat 5.x < 5.5.1 Information Disclosure

Medium Nessus Plugin ID 47028


The remote Apache Tomcat server is affected by an information disclosure vulnerability.


According to its self-reported version number, the instance of Apache Tomcat 5.x listening on the remote host is prior to 5.5.1. It is, therefore, affected by an information disclosure vulnerability.

Specifically, it may allow requests from a non-permitted IP address to gain access to a context that is protected with a valve that extends RequestFilterValve.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 5.5.1 or later.

See Also




Plugin Details

Severity: Medium

ID: 47028

File Name: tomcat_5_5_1.nasl

Version: $Revision: 1.11 $

Type: remote

Family: Web Servers

Published: 2010/06/16

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/10/09

Vulnerability Publication Date: 2008/10/09

Reference Information

CVE: CVE-2008-3271

BID: 31698

Secunia: 32213

OSVDB: 49062

CWE: 264