Apache Tomcat 6.x < 6.0.9 Information Disclosure

Medium Nessus Plugin ID 46869


The remote web server is affected by an information disclosure vulnerability.


According to its self-reported version number, the instance of Apache Tomcat 6.x listening on the remote host is prior to 6.0.9. It is, therefore, affected by an information disclosure vulnerability.

If the remote Apache Tomcat install is configured to use the SingleSignOn Valve, the JSESSIONIDSSO cookie does not have the 'secure' attribute set if authentication takes place over HTTPS. This allows the JSESSIONIDSSO cookie to be sent to the same server when HTTP content is requested.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 6.0.9 or later.

See Also


Plugin Details

Severity: Medium

ID: 46869

File Name: tomcat_6_0_9.nasl

Version: $Revision: 1.15 $

Type: remote

Family: Web Servers

Published: 2010/06/11

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:ND/RC:C


Base Score: 5.3

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:X/RL:X/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/01/31

Vulnerability Publication Date: 2006/12/20

Reference Information

CVE: CVE-2008-0128

BID: 27365

Secunia: 28552

OSVDB: 40853

CWE: 16