Wireshark / Ethereal < 1.0.14 / 1.2.9 Multiple Vulnerabilities

High Nessus Plugin ID 46864


The remote host has an application that is affected by multiple vulnerabilities.


The installed version of Wireshark or Ethereal is potentially affected by multiple vulnerabilities.

- The SMB dissector can be affected by a NULL pointer dereference. (Bug 4734)

- The ANS.1 BER dissector can be affected by a buffer overflow.

- The SMB PIPE dissector can be affected by a NULL pointer dereference on some platforms.

- The SigComp Universal Decompressor Virtual Machine can be affected by an infinite loop or a buffer overflow.
(Bug 4826, 4837)


Upgrade to Wireshark version 1.0.14 / 1.2.9 or later.

See Also



Plugin Details

Severity: High

ID: 46864

File Name: wireshark_1_2_9.nasl

Version: $Revision: 1.13 $

Type: local

Agent: windows

Family: Windows

Published: 2010/06/11

Modified: 2016/12/21

Dependencies: 34112

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/06/09

Vulnerability Publication Date: 2010/06/09

Reference Information

CVE: CVE-2010-2283, CVE-2010-2284, CVE-2010-2285, CVE-2010-2286, CVE-2010-2287

BID: 40728, 42618

OSVDB: 65371, 65372, 65373, 65374, 65375

Secunia: 40112