MS10-040: Vulnerability in Internet Information Services Could Allow Remote Code Execution (982666)

High Nessus Plugin ID 46847


The remote web server may allow remote code execution.


A remote code execution vulnerability exists in Internet Information Services (IIS). The vulnerability, which requires that the Extended Protection for Authentication feature be installed and enabled, is due to improper parsing of authentication information. An attacker who successfully exploited this vulnerability could execute code in the context of the Worker Process Identity (WPI).


Microsoft has released a set of patches for Windows 2003, Vista, 2008, 2008 R2 and 7.

See Also

Plugin Details

Severity: High

ID: 46847

File Name: smb_nt_ms10-040.nasl

Version: $Revision: 1.25 $

Type: local

Agent: windows

Published: 2010/06/09

Modified: 2017/07/26

Dependencies: 13855, 57033

Risk Information

Risk Factor: High


Base Score: 8.5

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/06/08

Vulnerability Publication Date: 2010/06/08

Reference Information

CVE: CVE-2010-1256

BID: 40573

OSVDB: 65216

IAVB: 2010-B-0045

MSFT: MS10-040

MSKB: 982666, 973917