Oracle OpenOffice.org < 3.2.1 Multiple Vulnerabilities

high Nessus Plugin ID 46814

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host has an application installed that is affected by multiple vulnerabilities.

Description

The version of Oracle OpenOffice.org installed on the remote host is prior to 3.2.1. It is, therefore, affected by several issues :

- There is a TLS/SSL renegotiation vulnerability in the included third-party OpenSSL library. (CVE-2009-3555)

- There is a python scripting vulnerability that could lead to undesired code execution when using the OpenOffice scripting IDE. (CVE-2010-0395)

Solution

Upgrade to Oracle OpenOffice.org version 3.2.1 or later.

See Also

http://www.openoffice.org/security/cves/CVE-2009-3555.html

http://www.openoffice.org/security/cves/CVE-2010-0395.html

Plugin Details

Severity: High

ID: 46814

File Name: openoffice_321.nasl

Version: 1.15

Type: local

Agent: windows

Family: Windows

Published: 6/7/2010

Updated: 7/16/2018

Dependencies: openoffice_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:openoffice.org

Required KB Items: SMB/OpenOffice/Build

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/7/2010

Vulnerability Publication Date: 11/9/2009

Reference Information

CVE: CVE-2009-3555, CVE-2010-0395

BID: 36935, 40599

CWE: 310