Oracle < 3.2.1 Multiple Vulnerabilities

High Nessus Plugin ID 46814


The remote Windows host has an application installed that is affected by multiple vulnerabilities.


The version of Oracle installed on the remote host is prior to 3.2.1. It is, therefore, affected by several issues :

- There is a TLS/SSL renegotiation vulnerability in the included third-party OpenSSL library. (CVE-2009-3555)

- There is a python scripting vulnerability that could lead to undesired code execution when using the OpenOffice scripting IDE. (CVE-2010-0395)


Upgrade to Oracle version 3.2.1 or later.

See Also

Plugin Details

Severity: High

ID: 46814

File Name: openoffice_321.nasl

Version: 1.15

Type: local

Agent: windows

Family: Windows

Published: 2010/06/07

Updated: 2018/07/16

Dependencies: 25551

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/

Required KB Items: SMB/OpenOffice/Build

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/06/07

Vulnerability Publication Date: 2009/11/09

Reference Information

CVE: CVE-2009-3555, CVE-2010-0395

BID: 36935, 40599

CWE: 310