OpenSSL < 0.9.8o / 1.0.0a Multiple Vulnerabilities

high Nessus Plugin ID 46801


The remote web server has a SSL-related vulnerability.


According to its banner, the remote web server is running a version of OpenSSL older than 0.9.8o / 1.0.0a. Such versions have the following vulnerabilities :

- The mishandling of Cryptographic Message Syntax structures containing an OriginatorInfo element can lead to data being written to invalid memory addresses or memory being freed up twice. (CVE-2010-0742)

- An uninitialized buffer of undefined length is returned when verification recovery fails for RSA keys. This allows an attacker to bypass key checks in applications calling the function EVP_PKEY_verify_recover(). Note this function is not used by OpenSSLcode itself. (CVE-2010-1633)


Upgrade to OpenSSL 0.9.8o / 1.0.0a or later.

See Also

Plugin Details

Severity: High

ID: 46801

File Name: openssl_1_0_0a.nasl

Version: 1.10

Type: remote

Family: Web Servers

Published: 6/3/2010

Updated: 7/16/2018

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 6/1/2010

Vulnerability Publication Date: 6/1/2010

Reference Information

CVE: CVE-2010-0742, CVE-2010-1633

BID: 40502, 40503

Secunia: 40024