Exim < 4.72 Multiple Vulnerabilities

medium Nessus Plugin ID 46783
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote mail server is potentially affected by multiple vulnerabilities.


The remote host is running Exim, a message transfer agent (SMTP).

According to the version number in its banner, the installed version of Exim is earlier than 4.72 and thus potentially affected by one or both of the following vulnerabilities :

- An error when handling hardlinks within the mail directory during the mail delivery process can be exploited to perform unauthorized actions.

- When MBX locking is enabled, a race condition exists that could allow an attacker to change permissions of other non-root users' files, leading to denial-of- service conditions or potentially privilege escalation.


Upgrade to Exim 4.72 or later when it becomes available.

See Also





Plugin Details

Severity: Medium

ID: 46783

File Name: exim_4_72.nasl

Version: 1.13

Type: remote

Published: 6/2/2010

Updated: 11/15/2018

Dependencies: smtpserver_detect.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 5.8


Risk Factor: Medium

Base Score: 6

Temporal Score: 4.4

Vector: AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport, SMTP/exim

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 5/24/2010

Reference Information

CVE: CVE-2010-2023, CVE-2010-2024

BID: 40451, 40454

Secunia: 40019