Exim < 4.72 Multiple Vulnerabilities

Medium Nessus Plugin ID 46783

Synopsis

The remote mail server is potentially affected by multiple vulnerabilities.

Description

The remote host is running Exim, a message transfer agent (SMTP).

According to the version number in its banner, the installed version of Exim is earlier than 4.72 and thus potentially affected by one or both of the following vulnerabilities :

- An error when handling hardlinks within the mail directory during the mail delivery process can be exploited to perform unauthorized actions.
(CVE-2010-2023)

- When MBX locking is enabled, a race condition exists that could allow an attacker to change permissions of other non-root users' files, leading to denial-of- service conditions or potentially privilege escalation.
(CVE-2010-2024)

Solution

Upgrade to Exim 4.72 or later when it becomes available.

See Also

https://lists.exim.org/lurker/message/20100524.175925.9a69f755.en.html

http://www.nessus.org/u?22b6761c

https://bugs.exim.org/show_bug.cgi?id=988

https://bugs.exim.org/show_bug.cgi?id=989

Plugin Details

Severity: Medium

ID: 46783

File Name: exim_4_72.nasl

Version: 1.13

Type: remote

Published: 2010/06/02

Updated: 2018/11/15

Dependencies: 10263

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport, SMTP/exim

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2010/05/24

Reference Information

CVE: CVE-2010-2023, CVE-2010-2024

BID: 40451, 40454

Secunia: 40019