Samba < 3.4.8 / 3.5.2 Session Setup AndX DoS

Medium Nessus Plugin ID 46351


The remote service is vulnerable to denial of service attacks.


According to its banner, the version of Samba installed on the remote host is a version of 3.4 before 3.4.8 or 3.5 < 3.5.2. Such versions are affected by two denial of service vulnerabilities that can be triggered via either a NULL pointer dereference or an uninitialized variable read.

By sending specially crafted 'Session Setup AndX' requests, an unauthenticated, remote attacker can exploit these vulnerabilities to crash the affected service, thereby denying service to legitimate users.


Upgrade to Samba 3.4.8 / 3.5.2 or later.

See Also

Plugin Details

Severity: Medium

ID: 46351

File Name: samba_3_5_2.nasl

Version: $Revision: 1.13 $

Type: remote

Family: Misc.

Published: 2010/05/17

Modified: 2014/08/20

Dependencies: 10785

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/05/11

Vulnerability Publication Date: 2010/05/12

Reference Information

CVE: CVE-2010-1635, CVE-2010-1642

BID: 40097

OSVDB: 65435, 65436