Opera < 10.53 Asynchronous Content Modification Uninitialized Memory Access

High Nessus Plugin ID 46204


The remote host contains a web browser that may allow code execution.


The version of Opera installed on the remote host is earlier than 10.53. Such versions are potentially affected by the following issue :

- Multiple asynchronous calls to a script that modifies document contents can be abused to reference an uninitialized value, leading to an application crash or possibly allowing execution of arbitrary code. (953)


Upgrade to Opera 10.53 or later.

See Also




Plugin Details

Severity: High

ID: 46204

File Name: opera_1053.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2010/04/30

Modified: 2014/01/03

Dependencies: 21746

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/04/30

Vulnerability Publication Date: 2010/04/27

Reference Information

CVE: CVE-2010-1728

BID: 39855

OSVDB: 64160

Secunia: 39590