Google Chrome < 4.1.249.1059 Multiple Vulnerabilities

high Nessus Plugin ID 45610

Synopsis

The remote host contains a web browser that is affected by multiple vulnerabilities.

Description

The version of Google Chrome installed on the remote host is earlier than 4.1.249.1059. Such versions are reportedly affected by multiple vulnerabilities :

- An error related to type confusion with forms.
(Issue #39443)

- An HTTP request error leading to a possible cross-site request forgery. (Issue #39698)

- A local file reference through developer tools.
(Issue #40136)

- A cross-site scripting issue in chrome://net-internals.
(Issue #40137)

- A cross-site scripting issue in chrome://downloads.
(Issue #40138)

- Pages might load with the privileges of the new tab page. (Issue #40575)

- A memory corruption vulnerability in V8 bindings.
(Issue #40635)

Solution

Upgrade to Google Chrome 4.1.249.1059 or later.

See Also

http://www.nessus.org/u?1c8d38da

Plugin Details

Severity: High

ID: 45610

File Name: google_chrome_4_1_249_1059.nasl

Version: 1.19

Type: local

Agent: windows

Family: Windows

Published: 4/23/2010

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 4/20/2010

Vulnerability Publication Date: 4/20/2010

Reference Information

CVE: CVE-2010-1500, CVE-2010-1502, CVE-2010-1503, CVE-2010-1504, CVE-2010-1505, CVE-2010-1506, CVE-2010-1767

BID: 39667, 39669, 39806, 39807, 39809, 39812, 39814

SECUNIA: 39544

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990