Firefox 3.6 < 3.6.3 Remote Code Execution

High Nessus Plugin ID 45403


The remote Windows host contains a web browser that is affected by a remote code execution vulnerability.


The installed version of Firefox 3.6.x is earlier than 3.6.3. Such versions are potentially affected by a memory corruption flaw caused by the re-use of an object that has been freed when moving DOM nodes between documents.

A remote attacker, exploiting this flaw, can leverage this issue to execute arbitrary code on the remote host subject to the privileges of the user running the affected application.


Upgrade to Firefox 3.6.3 or later.

See Also

Plugin Details

Severity: High

ID: 45403

File Name: mozilla_firefox_363.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Family: Windows

Published: 2010/04/02

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/04/01

Vulnerability Publication Date: 2010/03/24

Reference Information

CVE: CVE-2010-1121

BID: 38952

OSVDB: 63457

Secunia: 39175