Debian DSA-2018-1 : php5 - DoS (crash)

Medium Nessus Plugin ID 45094

Synopsis

The remote Debian host is missing a security-related update.

Description

Auke van Slooten discovered that PHP 5, an hypertext preprocessor, crashes (because of a NULL pointer dereference) when processing invalid XML-RPC requests.

Solution

Upgrade the php5 packages.

For the stable distribution (lenny), this problem has been fixed in version 5.2.6.dfsg.1-1+lenny8.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=573573

https://www.debian.org/security/2010/dsa-2018

Plugin Details

Severity: Medium

ID: 45094

File Name: debian_DSA-2018.nasl

Version: 1.10

Type: local

Agent: unix

Published: 2010/03/19

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:php5, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/03/18

Reference Information

CVE: CVE-2010-0397

BID: 38708

DSA: 2018