Apache 2.2.x < 2.2.15 Multiple Vulnerabilities

Critical Nessus Plugin ID 45004


The remote web server is affected by multiple vulnerabilities


According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.15. It is, therefore, potentially affected by multiple vulnerabilities :

- A TLS renegotiation prefix injection attack is possible. (CVE-2009-3555)

- The 'mod_proxy_ajp' module returns the wrong status code if it encounters an error which causes the back-end server to be put into an error state. (CVE-2010-0408)

- The 'mod_isapi' attempts to unload the 'ISAPI.dll' when it encounters various error states which could leave call-backs in an undefined state. (CVE-2010-0425)

- A flaw in the core sub-request process code can lead to sensitive information from a request being handled by the wrong thread if a multi-threaded environment is used. (CVE-2010-0434)

- Added 'mod_reqtimeout' module to mitigate Slowloris attacks. (CVE-2007-6750)


Upgrade to Apache version 2.2.15 or later.

See Also




Plugin Details

Severity: Critical

ID: 45004

File Name: apache_2_2_15.nasl

Version: $Revision: 1.34 $

Type: remote

Family: Web Servers

Published: 2010/10/20

Modified: 2018/01/23

Dependencies: 48204

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 9.8

Temporal Score: 9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/03/08

Vulnerability Publication Date: 2010/03/03

Exploitable With

Core Impact

Reference Information

CVE: CVE-2007-6750, CVE-2009-3555, CVE-2010-0408, CVE-2010-0425, CVE-2010-0434

BID: 21865, 36935, 38491, 38494, 38580

OSVDB: 59969, 62674, 62675, 62676

Secunia: 38776

CWE: 200, 310