Debian DSA-1998-1 : kdelibs - buffer overflow

Medium Nessus Plugin ID 44862

Synopsis

The remote Debian host is missing a security-related update.

Description

Maksymilian Arciemowicz discovered a buffer overflow in the internal string routines of the KDE core libraries, which could lead to the execution of arbitrary code.

Solution

Upgrade the kdelibs packages.

For the stable distribution (lenny), this problem has been fixed in version 4:3.5.10.dfsg.1-0lenny4.

See Also

https://www.debian.org/security/2010/dsa-1998

Plugin Details

Severity: Medium

ID: 44862

File Name: debian_DSA-1998.nasl

Version: 1.17

Type: local

Agent: unix

Published: 2010/02/24

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:kdelibs, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/02/17

Reference Information

CVE: CVE-2009-0689

BID: 35510

DSA: 1998

CWE: 119