Debian DSA-1974-1 : gzip - several vulnerabilities

Medium Nessus Plugin ID 44839

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been found in gzip, the GNU compression utilities. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2009-2624 Thiemo Nagel discovered a missing input sanitation flaw in the way gzip used to decompress data blocks for dynamic Huffman codes, which could lead to the execution of arbitrary code when trying to decompress a crafted archive. This issue is a reappearance of CVE-2006-4334 and only affects the lenny version.

- CVE-2010-0001 Aki Helin discovered an integer underflow when decompressing files that are compressed using the LZW algorithm. This could lead to the execution of arbitrary code when trying to decompress a crafted LZW compressed gzip archive.

Solution

Upgrade the gzip packages.

For the stable distribution (lenny), these problems have been fixed in version 1.3.12-6+lenny1.

For the oldstable distribution (etch), these problems have been fixed in version 1.3.5-15+etch1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507263

https://security-tracker.debian.org/tracker/CVE-2009-2624

https://security-tracker.debian.org/tracker/CVE-2006-4334

https://security-tracker.debian.org/tracker/CVE-2010-0001

https://www.debian.org/security/2010/dsa-1974

Plugin Details

Severity: Medium

ID: 44839

File Name: debian_DSA-1974.nasl

Version: 1.12

Type: local

Agent: unix

Published: 2010/02/24

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gzip, cpe:/o:debian:debian_linux:4.0, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/01/20

Reference Information

CVE: CVE-2009-2624, CVE-2010-0001

DSA: 1974

CWE: 20, 189