Debian DSA-1973-1 : glibc, eglibc - information disclosure

High Nessus Plugin ID 44838

Synopsis

The remote Debian host is missing a security-related update.

Description

Christoph Pleger has discovered that the GNU C Library (aka glibc) and its derivatives add information from the passwd.adjunct.byname map to entries in the passwd map, which allows local users to obtain the encrypted passwords of NIS accounts by calling the getpwnam function.

Solution

Upgrade the glibc or eglibc package.

For the oldstable distribution (etch), this problem has been fixed in version 2.3.6.ds1-13etch10 of the glibc package.

For the stable distribution (lenny), this problem has been fixed in version 2.7-18lenny2 of the glibc package.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=560333

https://www.debian.org/security/2010/dsa-1973

Plugin Details

Severity: High

ID: 44838

File Name: debian_DSA-1973.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2010/02/24

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:eglibc, p-cpe:/a:debian:debian_linux:glibc, cpe:/o:debian:debian_linux:4.0, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2010/01/19

Reference Information

CVE: CVE-2010-0015

DSA: 1973

CWE: 255