Debian DSA-1958-1 : libtool - privilege escalation

Medium Nessus Plugin ID 44823

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that ltdl, a system-independent dlopen wrapper for GNU libtool, can be tricked to load and run modules from an arbitrary directory, which might be used to execute arbitrary code with the privileges of the user running an application that uses libltdl.

Solution

Upgrade the libtool packages.

For the oldstable distribution (etch), this problem has been fixed in version 1.5.22-4+etch1.

For the stable distribution (lenny), this problem has been fixed in version 1.5.26-4+lenny1.

See Also

https://www.debian.org/security/2009/dsa-1958

Plugin Details

Severity: Medium

ID: 44823

File Name: debian_DSA-1958.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2010/02/24

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.9

Temporal Score: 5.1

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libtool, cpe:/o:debian:debian_linux:4.0, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/12/29

Reference Information

CVE: CVE-2009-3736

BID: 37128

DSA: 1958