Debian DSA-1931-1 : nspr - several vulnerabilities

Critical Nessus Plugin ID 44796

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in the NetScape Portable Runtime Library, which may lead to the execution of arbitrary code.
The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2009-1563 A programming error in the string handling code may lead to the execution of arbitrary code.

- CVE-2009-2463 An integer overflow in the Base64 decoding functions may lead to the execution of arbitrary code.

Solution

Upgrade the NSPR packages.

The old stable distribution (etch) doesn't contain nspr.

For the stable distribution (lenny), these problems have been fixed in version 4.7.1-5.

See Also

https://security-tracker.debian.org/tracker/CVE-2009-1563

https://security-tracker.debian.org/tracker/CVE-2009-2463

https://www.debian.org/security/2009/dsa-1931

Plugin Details

Severity: Critical

ID: 44796

File Name: debian_DSA-1931.nasl

Version: 1.19

Type: local

Agent: unix

Published: 2010/02/24

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:nspr, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/11/08

Reference Information

CVE: CVE-2009-0689, CVE-2009-2463

BID: 35769, 36851

DSA: 1931

CWE: 119, 189