Debian DSA-1908-1 : samba - several vulnerabilities

Medium Nessus Plugin ID 44773

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.1

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in samba, an implementation of the SMB/CIFS protocol for Unix systems, providing support for cross-platform file and printer sharing with other operating systems and more. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2009-2948 The mount.cifs utility is missing proper checks for file permissions when used in verbose mode. This allows local users to partly disclose the content of arbitrary files by specifying the file as credentials file and attempting to mount a samba share.

- CVE-2009-2906 A reply to an oplock break notification which samba doesn't expect could lead to the service getting stuck in an infinite loop. An attacker can use this to perform denial of service attacks via a specially crafted SMB request.

- CVE-2009-2813 A lack of error handling in case no home directory was configured/specified for the user could lead to file disclosure. In case the automated [homes] share is enabled or an explicit share is created with that username, samba fails to enforce sharing restrictions which results in an attacker being able to access the file system from the root directory.

Solution

Upgrade the samba packages.

For the oldstable distribution (etch), this problem will be fixed soon.

For the stable distribution (lenny), this problem has been fixed in version 2:3.2.5-4lenny7.

See Also

https://security-tracker.debian.org/tracker/CVE-2009-2948

https://security-tracker.debian.org/tracker/CVE-2009-2906

https://security-tracker.debian.org/tracker/CVE-2009-2813

https://www.debian.org/security/2009/dsa-1908

Plugin Details

Severity: Medium

ID: 44773

File Name: debian_DSA-1908.nasl

Version: 1.14

Type: local

Agent: unix

Published: 2010/02/24

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 6.1

CVSS v2.0

Base Score: 6

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:samba, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/10/14

Reference Information

CVE: CVE-2009-2813, CVE-2009-2906, CVE-2009-2948

BID: 36363, 36572, 36573

DSA: 1908

CWE: 264