Debian DSA-1877-1 : mysql-dfsg-5.0 - denial of service/execution of arbitrary code

High Nessus Plugin ID 44742

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7

Synopsis

The remote Debian host is missing a security-related update.

Description

In MySQL 4.0.0 through 5.0.83, multiple format string vulnerabilities in the dispatch_command() function in libmysqld/sql_parse.cc in mysqld allow remote authenticated users to cause a denial of service (daemon crash) and potentially the execution of arbitrary code via format string specifiers in a database name in a COM_CREATE_DB or COM_DROP_DB request.

Solution

Upgrade the mysql packages.

For the stable distribution (lenny), this problem has been fixed in version 5.0.51a-24+lenny2.

For the old stable distribution (etch), this problem has been fixed in version 5.0.32-7etch11.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=536726

https://www.debian.org/security/2009/dsa-1877

Plugin Details

Severity: High

ID: 44742

File Name: debian_DSA-1877.nasl

Version: 1.8

Type: local

Agent: unix

Published: 2010/02/24

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 8.5

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mysql-dfsg-5.0, cpe:/o:debian:debian_linux:4.0, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/09/02

Reference Information

CVE: CVE-2009-2446

BID: 35609

DSA: 1877

CWE: 134