Mandriva Linux Security Advisory : libtheora (MDVSA-2010:043)

High Nessus Plugin ID 44673


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability have been discovered and corrected in libtheora :

Integer overflow in libtheora in Xiph.Org Theora before 1.1 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a video with large dimensions (CVE-2009-3389).

The updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 44673

File Name: mandriva_MDVSA-2010-043.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2010/02/22

Modified: 2013/12/04

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64theora-devel, p-cpe:/a:mandriva:linux:lib64theora0, p-cpe:/a:mandriva:linux:lib64theoradec1, p-cpe:/a:mandriva:linux:lib64theoraenc1, p-cpe:/a:mandriva:linux:libtheora-devel, p-cpe:/a:mandriva:linux:libtheora0, p-cpe:/a:mandriva:linux:libtheoradec1, p-cpe:/a:mandriva:linux:libtheoraenc1, cpe:/o:mandriva:linux:2009.0, cpe:/o:mandriva:linux:2009.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/02/19

Reference Information

CVE: CVE-2009-3389

BID: 37368

MDVSA: 2010:043

CWE: 189