CentOS 3 / 4 / 5 : openoffice.org (CESA-2010:0101)

High Nessus Plugin ID 44598

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated openoffice.org packages that correct multiple security issues are now available for Red Hat Enterprise Linux 3, 4, and 5.

This update has been rated as having important security impact by the Red Hat Security Response Team.

OpenOffice.org is an office productivity suite that includes desktop applications, such as a word processor, spreadsheet application, presentation manager, formula editor, and a drawing program.

An integer overflow flaw, leading to a heap-based buffer overflow, was found in the way OpenOffice.org parsed XPM files. An attacker could create a specially crafted document, which once opened by a local, unsuspecting user, could lead to arbitrary code execution with the permissions of the user running OpenOffice.org. Note: This flaw affects embedded XPM files in OpenOffice.org documents as well as stand-alone XPM files. (CVE-2009-2949)

An integer underflow flaw and a boundary error flaw, both possibly leading to a heap-based buffer overflow, were found in the way OpenOffice.org parsed certain records in Microsoft Word documents. An attacker could create a specially crafted Microsoft Word document, which once opened by a local, unsuspecting user, could cause OpenOffice.org to crash or, potentially, execute arbitrary code with the permissions of the user running OpenOffice.org. (CVE-2009-3301, CVE-2009-3302)

A heap-based buffer overflow flaw, leading to memory corruption, was found in the way OpenOffice.org parsed GIF files. An attacker could create a specially crafted document, which once opened by a local, unsuspecting user, could cause OpenOffice.org to crash. Note: This flaw affects embedded GIF files in OpenOffice.org documents as well as stand-alone GIF files. (CVE-2009-2950)

All users of OpenOffice.org are advised to upgrade to these updated packages, which contain backported patches to correct these issues.
All running instances of OpenOffice.org applications must be restarted for this update to take effect.

Solution

Update the affected openoffice.org packages.

See Also

http://www.nessus.org/u?f08d475e

http://www.nessus.org/u?6cb82ae5

http://www.nessus.org/u?f09209c9

http://www.nessus.org/u?b4678357

http://www.nessus.org/u?39a00bda

http://www.nessus.org/u?a47bf970

Plugin Details

Severity: High

ID: 44598

File Name: centos_RHSA-2010-0101.nasl

Version: 1.20

Type: local

Agent: unix

Published: 2010/02/15

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:openoffice.org, p-cpe:/a:centos:centos:openoffice.org-base, p-cpe:/a:centos:centos:openoffice.org-calc, p-cpe:/a:centos:centos:openoffice.org-core, p-cpe:/a:centos:centos:openoffice.org-draw, p-cpe:/a:centos:centos:openoffice.org-emailmerge, p-cpe:/a:centos:centos:openoffice.org-graphicfilter, p-cpe:/a:centos:centos:openoffice.org-headless, p-cpe:/a:centos:centos:openoffice.org-i18n, p-cpe:/a:centos:centos:openoffice.org-impress, p-cpe:/a:centos:centos:openoffice.org-javafilter, p-cpe:/a:centos:centos:openoffice.org-kde, p-cpe:/a:centos:centos:openoffice.org-langpack-af_ZA, p-cpe:/a:centos:centos:openoffice.org-langpack-ar, p-cpe:/a:centos:centos:openoffice.org-langpack-as_IN, p-cpe:/a:centos:centos:openoffice.org-langpack-bg_BG, p-cpe:/a:centos:centos:openoffice.org-langpack-bn, p-cpe:/a:centos:centos:openoffice.org-langpack-ca_ES, p-cpe:/a:centos:centos:openoffice.org-langpack-cs_CZ, p-cpe:/a:centos:centos:openoffice.org-langpack-cy_GB, p-cpe:/a:centos:centos:openoffice.org-langpack-da_DK, p-cpe:/a:centos:centos:openoffice.org-langpack-de, p-cpe:/a:centos:centos:openoffice.org-langpack-el_GR, p-cpe:/a:centos:centos:openoffice.org-langpack-es, p-cpe:/a:centos:centos:openoffice.org-langpack-et_EE, p-cpe:/a:centos:centos:openoffice.org-langpack-eu_ES, p-cpe:/a:centos:centos:openoffice.org-langpack-fi_FI, p-cpe:/a:centos:centos:openoffice.org-langpack-fr, p-cpe:/a:centos:centos:openoffice.org-langpack-ga_IE, p-cpe:/a:centos:centos:openoffice.org-langpack-gl_ES, p-cpe:/a:centos:centos:openoffice.org-langpack-gu_IN, p-cpe:/a:centos:centos:openoffice.org-langpack-he_IL, p-cpe:/a:centos:centos:openoffice.org-langpack-hi_IN, p-cpe:/a:centos:centos:openoffice.org-langpack-hr_HR, p-cpe:/a:centos:centos:openoffice.org-langpack-hu_HU, p-cpe:/a:centos:centos:openoffice.org-langpack-it, p-cpe:/a:centos:centos:openoffice.org-langpack-ja_JP, p-cpe:/a:centos:centos:openoffice.org-langpack-kn_IN, p-cpe:/a:centos:centos:openoffice.org-langpack-ko_KR, p-cpe:/a:centos:centos:openoffice.org-langpack-lt_LT, p-cpe:/a:centos:centos:openoffice.org-langpack-ml_IN, p-cpe:/a:centos:centos:openoffice.org-langpack-mr_IN, p-cpe:/a:centos:centos:openoffice.org-langpack-ms_MY, p-cpe:/a:centos:centos:openoffice.org-langpack-nb_NO, p-cpe:/a:centos:centos:openoffice.org-langpack-nl, p-cpe:/a:centos:centos:openoffice.org-langpack-nn_NO, p-cpe:/a:centos:centos:openoffice.org-langpack-nr_ZA, p-cpe:/a:centos:centos:openoffice.org-langpack-nso_ZA, p-cpe:/a:centos:centos:openoffice.org-langpack-or_IN, p-cpe:/a:centos:centos:openoffice.org-langpack-pa_IN, p-cpe:/a:centos:centos:openoffice.org-langpack-pl_PL, p-cpe:/a:centos:centos:openoffice.org-langpack-pt_BR, p-cpe:/a:centos:centos:openoffice.org-langpack-pt_PT, p-cpe:/a:centos:centos:openoffice.org-langpack-ru, p-cpe:/a:centos:centos:openoffice.org-langpack-sk_SK, p-cpe:/a:centos:centos:openoffice.org-langpack-sl_SI, p-cpe:/a:centos:centos:openoffice.org-langpack-sr_CS, p-cpe:/a:centos:centos:openoffice.org-langpack-ss_ZA, p-cpe:/a:centos:centos:openoffice.org-langpack-st_ZA, p-cpe:/a:centos:centos:openoffice.org-langpack-sv, p-cpe:/a:centos:centos:openoffice.org-langpack-ta_IN, p-cpe:/a:centos:centos:openoffice.org-langpack-te_IN, p-cpe:/a:centos:centos:openoffice.org-langpack-th_TH, p-cpe:/a:centos:centos:openoffice.org-langpack-tn_ZA, p-cpe:/a:centos:centos:openoffice.org-langpack-tr_TR, p-cpe:/a:centos:centos:openoffice.org-langpack-ts_ZA, p-cpe:/a:centos:centos:openoffice.org-langpack-ur, p-cpe:/a:centos:centos:openoffice.org-langpack-ve_ZA, p-cpe:/a:centos:centos:openoffice.org-langpack-xh_ZA, p-cpe:/a:centos:centos:openoffice.org-langpack-zh_CN, p-cpe:/a:centos:centos:openoffice.org-langpack-zh_TW, p-cpe:/a:centos:centos:openoffice.org-langpack-zu_ZA, p-cpe:/a:centos:centos:openoffice.org-libs, p-cpe:/a:centos:centos:openoffice.org-math, p-cpe:/a:centos:centos:openoffice.org-pyuno, p-cpe:/a:centos:centos:openoffice.org-sdk, p-cpe:/a:centos:centos:openoffice.org-sdk-doc, p-cpe:/a:centos:centos:openoffice.org-testtools, p-cpe:/a:centos:centos:openoffice.org-writer, p-cpe:/a:centos:centos:openoffice.org-xsltfilter, p-cpe:/a:centos:centos:openoffice.org2-base, p-cpe:/a:centos:centos:openoffice.org2-calc, p-cpe:/a:centos:centos:openoffice.org2-core, p-cpe:/a:centos:centos:openoffice.org2-debuginfo, p-cpe:/a:centos:centos:openoffice.org2-draw, p-cpe:/a:centos:centos:openoffice.org2-emailmerge, p-cpe:/a:centos:centos:openoffice.org2-graphicfilter, p-cpe:/a:centos:centos:openoffice.org2-impress, p-cpe:/a:centos:centos:openoffice.org2-javafilter, p-cpe:/a:centos:centos:openoffice.org2-langpack-af_ZA, p-cpe:/a:centos:centos:openoffice.org2-langpack-ar, p-cpe:/a:centos:centos:openoffice.org2-langpack-bg_BG, p-cpe:/a:centos:centos:openoffice.org2-langpack-bn, p-cpe:/a:centos:centos:openoffice.org2-langpack-ca_ES, p-cpe:/a:centos:centos:openoffice.org2-langpack-cs_CZ, p-cpe:/a:centos:centos:openoffice.org2-langpack-cy_GB, p-cpe:/a:centos:centos:openoffice.org2-langpack-da_DK, p-cpe:/a:centos:centos:openoffice.org2-langpack-de, p-cpe:/a:centos:centos:openoffice.org2-langpack-el_GR, p-cpe:/a:centos:centos:openoffice.org2-langpack-es, p-cpe:/a:centos:centos:openoffice.org2-langpack-et_EE, p-cpe:/a:centos:centos:openoffice.org2-langpack-eu_ES, p-cpe:/a:centos:centos:openoffice.org2-langpack-fi_FI, p-cpe:/a:centos:centos:openoffice.org2-langpack-fr, p-cpe:/a:centos:centos:openoffice.org2-langpack-ga_IE, p-cpe:/a:centos:centos:openoffice.org2-langpack-gl_ES, p-cpe:/a:centos:centos:openoffice.org2-langpack-gu_IN, p-cpe:/a:centos:centos:openoffice.org2-langpack-he_IL, p-cpe:/a:centos:centos:openoffice.org2-langpack-hi_IN, p-cpe:/a:centos:centos:openoffice.org2-langpack-hr_HR, p-cpe:/a:centos:centos:openoffice.org2-langpack-hu_HU, p-cpe:/a:centos:centos:openoffice.org2-langpack-it, p-cpe:/a:centos:centos:openoffice.org2-langpack-ja_JP, p-cpe:/a:centos:centos:openoffice.org2-langpack-ko_KR, p-cpe:/a:centos:centos:openoffice.org2-langpack-lt_LT, p-cpe:/a:centos:centos:openoffice.org2-langpack-ms_MY, p-cpe:/a:centos:centos:openoffice.org2-langpack-nb_NO, p-cpe:/a:centos:centos:openoffice.org2-langpack-nl, p-cpe:/a:centos:centos:openoffice.org2-langpack-nn_NO, p-cpe:/a:centos:centos:openoffice.org2-langpack-pa_IN, p-cpe:/a:centos:centos:openoffice.org2-langpack-pl_PL, p-cpe:/a:centos:centos:openoffice.org2-langpack-pt_BR, p-cpe:/a:centos:centos:openoffice.org2-langpack-pt_PT, p-cpe:/a:centos:centos:openoffice.org2-langpack-ru, p-cpe:/a:centos:centos:openoffice.org2-langpack-sk_SK, p-cpe:/a:centos:centos:openoffice.org2-langpack-sl_SI, p-cpe:/a:centos:centos:openoffice.org2-langpack-sr_CS, p-cpe:/a:centos:centos:openoffice.org2-langpack-sv, p-cpe:/a:centos:centos:openoffice.org2-langpack-ta_IN, p-cpe:/a:centos:centos:openoffice.org2-langpack-th_TH, p-cpe:/a:centos:centos:openoffice.org2-langpack-tr_TR, p-cpe:/a:centos:centos:openoffice.org2-langpack-zh_CN, p-cpe:/a:centos:centos:openoffice.org2-langpack-zh_TW, p-cpe:/a:centos:centos:openoffice.org2-langpack-zu_ZA, p-cpe:/a:centos:centos:openoffice.org2-math, p-cpe:/a:centos:centos:openoffice.org2-pyuno, p-cpe:/a:centos:centos:openoffice.org2-testtools, p-cpe:/a:centos:centos:openoffice.org2-writer, p-cpe:/a:centos:centos:openoffice.org2-xsltfilter, cpe:/o:centos:centos:3, cpe:/o:centos:centos:4, cpe:/o:centos:centos:5

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/02/17

Vulnerability Publication Date: 2010/02/16

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-2949, CVE-2009-2950, CVE-2009-3301, CVE-2009-3302

BID: 38218

RHSA: 2010:0101

CWE: 94, 119, 189