Adobe AIR < 1.5.3.9130 Multiple Vulnerabilities (APSB10-06)

medium Nessus Plugin ID 44595

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host contains a version of Adobe AIR that is affected by multiple vulnerabilities.

Description

The remote Windows host contains a version of Adobe AIR that is earlier than 1.5.3.9130 Such versions are potentially affected by multiple vulnerabilities :

- An issue that could subvert the domain sandbox and make unauthorized cross-domain requests. (CVE-2010-0186)

- An unspecified denial of service. (CVE-2010-0187)

Solution

Upgrade to Adobe AIR 1.5.3.9130 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb10-06.html

Plugin Details

Severity: Medium

ID: 44595

File Name: adobe_air_apsb10-06.nasl

Version: 1.11

Type: local

Agent: windows

Family: Windows

Published: 2/12/2010

Updated: 6/27/2018

Dependencies: adobe_air_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:air

Required KB Items: SMB/Adobe_AIR/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/11/2010

Vulnerability Publication Date: 2/11/2010

Reference Information

CVE: CVE-2010-0186, CVE-2010-0187

BID: 38198, 38200

Secunia: 38547

CWE: 94