MS10-005: Vulnerability in Microsoft Paint Could Allow Remote Code Execution (978706)

High Nessus Plugin ID 44415


Arbitrary code can be executed on the remote host through Microsoft Paint.


The remote Windows host is running a version of Microsoft Paint that has an integer overflow vulnerability that can be triggered when decoding JPEG images.

If an attacker can trick a user on the affected host into opening a specially crafted JPEG image file using Microsoft Paint, he may be able to leverage these issues to execute arbitrary code subject to the user's privileges.


Microsoft has released a set of patches for Windows 2000, XP, and 2003.

See Also

Plugin Details

Severity: High

ID: 44415

File Name: smb_nt_ms10-005.nasl

Version: $Revision: 1.20 $

Type: local

Agent: windows

Published: 2010/02/09

Modified: 2017/07/26

Dependencies: 57033, 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/02/09

Vulnerability Publication Date: 2010/02/09

Reference Information

CVE: CVE-2010-0028

BID: 38042

OSVDB: 62242

MSFT: MS10-005

IAVB: 2010-B-0014

MSKB: 978706

CWE: 189