Wireshark / Ethereal Dissector LWRES Multiple Buffer Overflows

High Nessus Plugin ID 44338


The remote host has an application that is affected by several buffer overflows.


The installed version of Wireshark or Ethereal is potentially vulnerable to attack by handling data associated with the LWRES dissector.

These vulnerabilities can result in a denial of service, or possibly arbitrary code execution. A remote attacker can exploit these issues by tricking a user into opening a maliciously crafted capture file. Additionally, if Wireshark is running in promiscuous mode, one of these issues can be exploited remotely.


Upgrade to Wireshark version 1.0.11 / 1.2.6 or later.

See Also


Plugin Details

Severity: High

ID: 44338

File Name: wireshark_1_2_6.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2010/01/29

Modified: 2016/11/29

Dependencies: 34112

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/01/27

Vulnerability Publication Date: 2010/01/27

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (Wireshark LWRES Dissector getaddrsbyname_request Buffer Overflow (loop))

Reference Information

CVE: CVE-2010-0304

BID: 37985

OSVDB: 61987

CWE: 119