Apache Tomcat WAR Deployment Multiple Vulnerabilities

Medium Nessus Plugin ID 44314

Synopsis

The web server running on the remote host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote host is running a version of Apache Tomcat that is affected by multiple vulnerabilities :

- When deploying WAR files, the WAR files are not checked for directory traversal attempts which could allow an attacker to create arbitrary content outside of the web root. (CVE-2009-2693)

- By default, Tomcat automatically deploys any directories placed in a host's appBase. This could lead to files which are normally protected by one or more security constraints being deployed without those security constraints. (CVE-2009-2901)

- When deploying WAR files, the WAR file names are not checked for directory traversal attempts which could allow an attacker to caused the deletion of the current contents of the host's work directory. (CVE-2009-2902).

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Tomcat version 6.0.24 / 5.5.29 or later.

See Also

http://tomcat.apache.org/security-5.html

http://tomcat.apache.org/security-6.html

https://www.securityfocus.com/archive/1/509148/30/0/threaded

https://www.securityfocus.com/archive/1/509150/30/0/threaded

https://www.securityfocus.com/archive/1/509151/30/0/threaded

Plugin Details

Severity: Medium

ID: 44314

File Name: tomcat_war_deploy_multiple_vulnerabilities.nasl

Version: 1.23

Type: remote

Family: Web Servers

Published: 2010/01/26

Updated: 2018/11/15

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2009-2693

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/01/25

Vulnerability Publication Date: 2010/01/25

Reference Information

CVE: CVE-2009-2693, CVE-2009-2901, CVE-2009-2902

BID: 37942, 37944, 37945

Secunia: 38316, 38346

CWE: 22, 264