OpenSSH < 5.7 Multiple Vulnerabilities

High Nessus Plugin ID 44081


The remote SSH service may be affected by multiple vulnerabilities.


According to its banner, the version of OpenSSH running on the remote host is earlier than 5.7. Versions before 5.7 may be affected by the following vulnerabilities :

- A security bypass vulnerability because OpenSSH does not properly validate the public parameters in the J-PAKE protocol. This could allow an attacker to authenticate without the shared secret. Note that this issue is only exploitable when OpenSSH is built with J-PAKE support, which is currently experimental and disabled by default, and that Nessus has not checked whether J-PAKE support is indeed enabled. (CVE-2010-4478)

- The auth_parse_options function in auth-options.c in sshd provides debug messages containing authorized_keys command options, which allows remote, authenticated users to obtain potentially sensitive information by reading these messages. (CVE-2012-0814)


Upgrade to OpenSSH 5.7 or later.

See Also

Plugin Details

Severity: High

ID: 44081

File Name: openssh_57.nasl

Version: $Revision: 1.9 $

Type: remote

Family: Misc.

Published: 2011/10/04

Modified: 2018/02/20

Dependencies: 10267

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/09/20

Vulnerability Publication Date: 2010/09/12

Reference Information

CVE: CVE-2010-4478, CVE-2012-0814

BID: 45304, 51702

OSVDB: 69658, 78706