OpenSSH < 4.7 Trusted X11 Cookie Connection Policy Bypass

High Nessus Plugin ID 44078


Remote attackers may be able to bypass authentication.


According to the banner, OpenSSH earlier than 4.7 is running on the remote host. Such versions contain an authentication bypass vulnerability. In the event that OpenSSH cannot create an untrusted cookie for X, for example due to the temporary partition being full, it will use a trusted cookie instead. This allows attackers to violate intended policy and gain privileges by causing their X client to be treated as trusted.


Upgrade to OpenSSH 4.7 or later.

See Also

Plugin Details

Severity: High

ID: 44078

File Name: openssh_47.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Misc.

Published: 2011/10/04

Modified: 2016/12/07

Dependencies: 10267

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/09/05

Vulnerability Publication Date: 2007/09/05

Reference Information

CVE: CVE-2007-4752, CVE-2007-2243

BID: 25628

OSVDB: 34600, 43371

CWE: 20, 287