OpenSSH < 3.2.3 YP Netgroups Authentication Bypass

High Nessus Plugin ID 44072


The remote SSH server has an authentication bypass vulnerability.


According to its banner, the version of OpenSSH running on the remote host is older than 3.2.3. It therefore may be affected by an authentication bypass issue. On systems using YP with netgroups, sshd authenticates users via ACL by checking for the requested username and password. Under certain conditions when doing ACL checks, it may instead use the password entry of a different user for authentication. This means unauthorized users could authenticate successfully, and authorized users could be locked out.


Upgrade to OpenSSH 3.2.3 or later.

See Also

Plugin Details

Severity: High

ID: 44072

File Name: openssh_323.nasl

Version: $Revision: 1.3 $

Type: remote

Published: 2011/10/04

Modified: 2016/07/06

Dependencies: 10267

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2002/05/22

Vulnerability Publication Date: 2002/05/16

Reference Information

CVE: CVE-2002-0765

BID: 4803

OSVDB: 5113