OpenSSH < 2.9.9 / 2.9p2 Symbolic Link 'cookies' File Removal

Low Nessus Plugin ID 44071


Local attackers may be able to delete arbitrary files.


According to the banner, OpenSSH earlier than 2.9.9 / 2.9p2 is running on the remote host. Such versions contain an arbitrary file deletion vulnerability. Due to insecure handling of temporary files, a local attacker can cause sshd to delete any file it can access named 'cookies'.


Upgrade to OpenSSH 2.9.9 / 2.9p2 or later.

See Also

Plugin Details

Severity: Low

ID: 44071

File Name: openssh_29p2.nasl

Version: $Revision: 1.3 $

Type: remote

Family: Misc.

Published: 2011/10/04

Modified: 2016/12/07

Dependencies: 10267

Risk Information

Risk Factor: Low


Base Score: 3.3

Temporal Score: 2.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2001/09/26

Vulnerability Publication Date: 2001/06/04

Reference Information

CVE: CVE-2001-0529

BID: 2825

OSVDB: 1853