OpenSSH < 2.9.9p1 Resource Limit Bypass

High Nessus Plugin ID 44069


The remote SSH service is affected by a denial of service vulnerability.


According to its banner, the remote host is running a version of OpenSSH earlier than 2.9.9p1. Such versions fail to initiate a Pluggable Authentication Module (PAM) session if commands are executed with no pty. A remote, unauthenticated attacker, exploiting this flaw, could bypass resource limits (rlimits) set in pam.d.


Upgrade to OpenSSH 2.9.9p1 or later.

See Also

Plugin Details

Severity: High

ID: 44069

File Name: openssh_299p1.nasl

Version: $Revision: 1.3 $

Type: remote

Family: Misc.

Published: 2011/10/04

Modified: 2012/12/10

Dependencies: 10267

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:ND

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2001/06/19

Reference Information

CVE: CVE-2001-1459

BID: 2917

OSVDB: 18236

CERT: 797027