CentOS 5 : firefox (CESA-2008:0597)

High Nessus Plugin ID 43699

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated firefox packages that fix various security issues are now available for Red Hat Enterprise Linux 5.

This update has been rated as having critical security impact by the Red Hat Security Response Team.

[Updated 16th July 2008] The nspluginwrapper package has been added to this advisory to satisfy a missing package dependency issue.

Mozilla Firefox is an open source Web browser.

An integer overflow flaw was found in the way Firefox displayed certain web content. A malicious website could cause Firefox to crash, or execute arbitrary code with the permissions of the user running Firefox. (CVE-2008-2785)

A flaw was found in the way Firefox handled certain command line URLs.
If another application passed Firefox a malformed URL, it could result in Firefox executing local malicious content with chrome privileges.
(CVE-2008-2933)

All firefox users should upgrade to these updated packages, which contain Firefox 3.0.1 that corrects these issues.

Solution

Update the affected firefox packages.

See Also

http://www.nessus.org/u?f663be08

http://www.nessus.org/u?3030948c

Plugin Details

Severity: High

ID: 43699

File Name: centos_RHSA-2008-0597.nasl

Version: 1.15

Type: local

Agent: unix

Published: 2010/01/06

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:devhelp, p-cpe:/a:centos:centos:devhelp-devel, p-cpe:/a:centos:centos:firefox, p-cpe:/a:centos:centos:xulrunner, p-cpe:/a:centos:centos:xulrunner-devel, p-cpe:/a:centos:centos:xulrunner-devel-unstable, cpe:/o:centos:centos:5

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/07/16

Vulnerability Publication Date: 2008/06/19

Reference Information

CVE: CVE-2008-2785, CVE-2008-2933, CVE-2008-3198

BID: 29802, 30242

RHSA: 2008:0597

CWE: 20, 94, 189