Mandriva Linux Security Advisory : acpid (MDVSA-2009:343)

Medium Nessus Plugin ID 43605


The remote Mandriva Linux host is missing a security update.


A vulnerability has been found and corrected in acpid :

acpid 1.0.4 sets an unrestrictive umask, which might allow local users to leverage weak permissions on /var/log/acpid, and obtain sensitive information by reading this file or cause a denial of service by overwriting this file, a different vulnerability than CVE-2009-4033 (CVE-2009-4235).

Packages for 2008.0 are provided for Corporate Desktop 2008.0 customers.

This update provides a solution to this vulnerability.


Update the affected acpid package.

Plugin Details

Severity: Medium

ID: 43605

File Name: mandriva_MDVSA-2009-343.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2009/12/28

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:acpid, cpe:/o:mandriva:linux:2008.0, cpe:/o:mandriva:linux:2009.0, cpe:/o:mandriva:linux:2009.1, cpe:/o:mandriva:linux:2010.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2009/12/26

Reference Information

CVE: CVE-2009-4235

MDVSA: 2009:343

CWE: 264