Wireshark / Ethereal 0.9.0 to 1.2.4 Multiple Vulnerabilities

High Nessus Plugin ID 43350


The remote host has an application that is affected by multiple vulnerabilities


The installed version of Wireshark or Ethereal is potentially affected by multiple vulnerabilities :

- The Daintree SNA file parser can overflow a buffer.
(Bug 4294)

- The SMB and SMB2 dissectors can crash. (Bug 4301)

- The IPMI dissector can crash on Windows. (Bug 4319)

These vulnerabilities can result in a denial of service, or possibly arbitrary code execution. A remote attacker can exploit these issues by tricking a user into opening a maliciously crafted capture file. Additionally, if Wireshark is running in promiscuous mode, one of these issues can be exploited remotely (from the same network segment).


Upgrade to Wireshark version 1.2.5 or later.

See Also





Plugin Details

Severity: High

ID: 43350

File Name: wireshark_1_2_5.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2009/12/18

Modified: 2013/03/21

Dependencies: 34112

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/12/17

Vulnerability Publication Date: 2009/12/17

Reference Information

CVE: CVE-2009-4376, CVE-2009-4377, CVE-2009-4378

BID: 37407

OSVDB: 61177, 61178, 61179

Secunia: 37842

CWE: 119