Fedora 12 : tomcat-native-1.1.18-1.fc12 (2009-12229)

Medium Nessus Plugin ID 43327

Synopsis

The remote Fedora host is missing a security update.

Description

Update to 1.1.18, implementing a mitigation for CVE-2009-3555.
http://tomcat.apache.org/native-doc/miscellaneous/changelog-1.1.x.html http://marc.info/?l=tomcat-dev&m=125900987921402&w=2 http://marc.info/?l =tomcat-dev&m=125874793414940&w=2 http://marc.info/?l=tomcat- user&m=125874793614950&w=2

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected tomcat-native package.

See Also

https://marc.info/?l

https://marc.info/?l=tomcat-

https://marc.info/?l=tomcat-dev&m=125900987921402&w=2

http://tomcat.apache.org/native-doc/miscellaneous/changelog-1.1.x.html

http://www.nessus.org/u?eb03b77e

Plugin Details

Severity: Medium

ID: 43327

File Name: fedora_2009-12229.nasl

Version: 1.18

Type: local

Agent: unix

Published: 2009/12/18

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:tomcat-native, cpe:/o:fedoraproject:fedora:12

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/11/27

Reference Information

CVE: CVE-2009-3555

BID: 36935

FEDORA: 2009-12229

CWE: 310