Mandriva Linux Security Advisory : gimp (MDVSA-2009:296-1)

High Nessus Plugin ID 43144


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability was discovered and corrected in gimp :

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a BMP file with crafted width and height values that trigger a heap-based buffer overflow (CVE-2009-1570).

This update provides a solution to this vulnerability.

Update :

Packages for 2008.0 are provided for Corporate Desktop 2008.0 customers


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 43144

File Name: mandriva_MDVSA-2009-296.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2009/12/14

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gimp, p-cpe:/a:mandriva:linux:gimp-python, p-cpe:/a:mandriva:linux:lib64gimp2.0-devel, p-cpe:/a:mandriva:linux:lib64gimp2.0_0, p-cpe:/a:mandriva:linux:libgimp2.0-devel, p-cpe:/a:mandriva:linux:libgimp2.0_0, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/12/11

Reference Information

CVE: CVE-2009-1570

BID: 37006

MDVSA: 2009:296-1

CWE: 189