Ubuntu 8.10 / 9.04 / 9.10 : kde4libs vulnerabilities (USN-871-2)

High Nessus Plugin ID 43110


The remote Ubuntu host is missing one or more security-related patches.


USN-871-1 fixed vulnerabilities in KDE. This update provides the corresponding updates for KDE 4.

This update also fixes a directory traversal flaw in KDE when processing help:// URLs. This issue only affected Ubuntu 8.10.

It was discovered that the KDE libraries could use KHTML to process an unknown MIME type. If a user or application linked against kdelibs were tricked into opening a crafted file, an attacker could potentially trigger XMLHTTPRequests to remote sites.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 43110

File Name: ubuntu_USN-871-2.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2009/12/11

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:kdelibs-bin, p-cpe:/a:canonical:ubuntu_linux:kdelibs5, p-cpe:/a:canonical:ubuntu_linux:kdelibs5-data, p-cpe:/a:canonical:ubuntu_linux:kdelibs5-dbg, p-cpe:/a:canonical:ubuntu_linux:kdelibs5-dev, p-cpe:/a:canonical:ubuntu_linux:kdelibs5-doc, p-cpe:/a:canonical:ubuntu_linux:libplasma-dev, p-cpe:/a:canonical:ubuntu_linux:libplasma3, cpe:/o:canonical:ubuntu_linux:8.10, cpe:/o:canonical:ubuntu_linux:9.04, cpe:/o:canonical:ubuntu_linux:9.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2009/12/10

Reference Information

OSVDB: 60913

USN: 871-2