Opera < 10.10 Multiple Vulnerabilities

High Nessus Plugin ID 42892


The remote host contains a web browser that is affected by multiple issues.


The version of Opera installed on the remote host is earlier than 10.10. Such versions are potentially affected by multiple issues :

- Error messages can leak onto unrelated sites which could lead to cross-site scripting attacks. (941)

- Passing very long strings through the string to number conversion using JavaScript in Opera may result in heap buffer overflows. (942)
- There is an as-yet unspecified moderately severe issue reported by Chris Evans of the Google Security Team.


Upgrade to Opera 10.10 or later.

See Also





Plugin Details

Severity: High

ID: 42892

File Name: opera_1010.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2009/11/25

Modified: 2016/12/07

Dependencies: 21746

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/11/23

Vulnerability Publication Date: 2009/11/20

Reference Information

CVE: CVE-2009-0689, CVE-2009-4071, CVE-2009-4072

BID: 37078, 37089

OSVDB: 60527, 60528

Secunia: 37469

CWE: 16, 119