eMule IRC Module / Web Server DecodeBase16 Function Remote Overflow

High Nessus Plugin ID 42833


Arbitrary code may be run on this host.


According to its version, the eMule Web Server listening on this port contains a buffer overflow vulnerability in the 'DecodeBase16' function due to a lack of length checks on its inputs. An anonymous remote attacker may be able to leverage this issue to execute arbitrary code on the affected host.


Either upgrade to eMule version 0.42e or later, do not use the eMule web server and IRC client, or uninstall eMule.

See Also



Plugin Details

Severity: High

ID: 42833

File Name: eMule_http_flaws.nasl

Version: $Revision: 1.5 $

Type: remote

Published: 2009/11/17

Modified: 2011/03/21

Dependencies: 12233

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2004/04/05

Reference Information

CVE: CVE-2004-1892

BID: 10039

OSVDB: 4937