Safari < 4.0.4 Multiple Vulnerabilities

High Nessus Plugin ID 42478

Synopsis

The remote host contains a web browser that is affected by several vulnerabilities.

Description

The version of Safari installed on the remote Windows host is earlier than 4.0.4. Such versions are potentially affected by several issues :

- An integer overflow in the handling of images with an embedded color profile could lead to a crash or arbitrary code execution. (CVE-2009-2804)

- Multiple use-after-free issues exist in libxml2, the most serious of which could lead to a program crash.
(CVE-2009-2414, CVE-2009-2416)

- An issue in the handling of navigations initiated via the 'Open Image in New Tab', 'Open Image in New Window' or 'Open Link in New Tab' shortcut menu options could be exploited to load a local HTML file, leading to disclosure of sensitive information. (CVE-2009-2842)

- An issue involving WebKit's inclusion of custom HTTP headers specified by a requesting page in preflight requests in support of Cross-Origin Resource Sharing can facilitate cross-site request forgery attacks. (CVE-2009-2816)

- Multiple issues in WebKit's handling of FTP directory listings may lead to information disclosure, unexpected application termination, or execution of arbitrary code. (CVE-2009-3384)

Solution

Upgrade to Safari 4.0.4 or later.

See Also

http://support.apple.com/kb/HT3949

http://lists.apple.com/archives/security-announce/2009/Nov/msg00001.html

http://www.securityfocus.com/advisories/18277

Plugin Details

Severity: High

ID: 42478

File Name: safari_4_0_4.nasl

Version: 1.16

Type: local

Agent: windows

Family: Windows

Published: 2009/11/12

Updated: 2018/07/27

Dependencies: 31788

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: SMB/Safari/FileVersion

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/11/11

Vulnerability Publication Date: 2009/11/11

Reference Information

CVE: CVE-2009-2804, CVE-2009-2414, CVE-2009-2416, CVE-2009-2816, CVE-2009-2842, CVE-2009-3384

BID: 36357, 36994, 36995, 36997

CWE: 119, 189, 352, 399