RHEL 3 : samba (RHSA-2009:1528)

Medium Nessus Plugin ID 42285


The remote Red Hat host is missing one or more security updates.


Updated samba packages that fix a security issue and a bug are now available for Red Hat Enterprise Linux 3.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

Samba is a suite of programs used by machines to share files, printers, and other information.

A denial of service flaw was found in the Samba smbd daemon. An authenticated, remote user could send a specially crafted response that would cause an smbd child process to enter an infinite loop. An authenticated, remote user could use this flaw to exhaust system resources by opening multiple CIFS sessions. (CVE-2009-2906)

This update also fixes the following bug :

* the RHSA-2007:0354 update added code to escape input passed to scripts that are run by Samba. This code was missing 'c' from the list of valid characters, causing it to be escaped. With this update, the previous patch has been updated to include 'c' in the list of valid characters. (BZ#242754)

Users of Samba should upgrade to these updated packages, which contain a backported patch to correct this issue. After installing this update, the smb service will be restarted automatically.


Update the affected packages.

See Also



Plugin Details

Severity: Medium

ID: 42285

File Name: redhat-RHSA-2009-1528.nasl

Version: $Revision: 1.21 $

Type: local

Agent: unix

Published: 2009/10/28

Modified: 2017/01/03

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:samba, p-cpe:/a:redhat:enterprise_linux:samba-client, p-cpe:/a:redhat:enterprise_linux:samba-common, p-cpe:/a:redhat:enterprise_linux:samba-swat, cpe:/o:redhat:enterprise_linux:3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/10/27

Reference Information

CVE: CVE-2009-2906

BID: 36573

RHSA: 2009:1528