Fedora 10 : Django-1.1.1-1.fc10 (2009-10432)

High Nessus Plugin ID 42153


The remote Fedora host is missing a security update.


http://www.djangoproject.com/weblog/2009/oct/09/security/ Description of vulnerability ============================ Django's forms library included field types which perform regular-expression-based validation of email addresses and URLs. Certain addresses/URLs could trigger a pathological performance case in this regular expression, resulting in the server process/thread becoming unresponsive, and consuming excessive CPU over an extended period of time. If deliberately triggered, this could result in an effective denial-of-service attack.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected Django package.

See Also




Plugin Details

Severity: High

ID: 42153

File Name: fedora_2009-10432.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2009/10/16

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:Django, cpe:/o:fedoraproject:fedora:10

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2009/10/14

Reference Information

FEDORA: 2009-10432