Ubuntu 8.04 LTS / 8.10 / 9.04 : icu vulnerability (USN-846-1)

Medium Nessus Plugin ID 42081


The remote Ubuntu host is missing one or more security-related patches.


It was discovered that ICU did not properly handle invalid byte sequences during Unicode conversion. If an application using ICU processed crafted data, content security mechanisms could be bypassed, potentially leading to cross-site scripting (XSS) attacks.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 42081

File Name: ubuntu_USN-846-1.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2009/10/09

Modified: 2016/07/06

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:icu-doc, p-cpe:/a:canonical:ubuntu_linux:lib32icu-dev, p-cpe:/a:canonical:ubuntu_linux:lib32icu38, p-cpe:/a:canonical:ubuntu_linux:libicu-dev, p-cpe:/a:canonical:ubuntu_linux:libicu38, p-cpe:/a:canonical:ubuntu_linux:libicu38-dbg, cpe:/o:canonical:ubuntu_linux:8.04:-:lts, cpe:/o:canonical:ubuntu_linux:8.10, cpe:/o:canonical:ubuntu_linux:9.04

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/10/08

Reference Information

CVE: CVE-2009-0153

OSVDB: 54447

USN: 846-1

CWE: 79