Mandriva Linux Security Advisory : snort (MDVSA-2009:259-1)

Medium Nessus Plugin ID 42063


The remote Mandriva Linux host is missing one or more security updates.


preprocessors/spp_frag3.c in Sourcefire Snort before 2.8.1 does not properly identify packet fragments that have dissimilar TTL values, which allows remote attackers to bypass detection rules by using a different TTL for each fragment. (CVE-2008-1804)

The updated packages have been patched to prevent this.

Additionally there were problems with two rules in the snort-rules package for 2008.0 that is also fixed with this update.

Update :

Packages for 2008.0 are provided for Corporate Desktop 2008.0 customers


Update the affected packages.

Plugin Details

Severity: Medium

ID: 42063

File Name: mandriva_MDVSA-2009-259.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2009/10/08

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:snort, p-cpe:/a:mandriva:linux:snort-bloat, p-cpe:/a:mandriva:linux:snort-inline, p-cpe:/a:mandriva:linux:snort-inline+flexresp, p-cpe:/a:mandriva:linux:snort-mysql, p-cpe:/a:mandriva:linux:snort-mysql+flexresp, p-cpe:/a:mandriva:linux:snort-plain+flexresp, p-cpe:/a:mandriva:linux:snort-postgresql, p-cpe:/a:mandriva:linux:snort-postgresql+flexresp, p-cpe:/a:mandriva:linux:snort-prelude, p-cpe:/a:mandriva:linux:snort-prelude+flexresp, p-cpe:/a:mandriva:linux:snort-rules, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2009/12/11

Reference Information

CVE: CVE-2008-1804

MDVSA: 2009:259-1