Apache 2.2.x < 2.2.14 Multiple Vulnerabilities

High Nessus Plugin ID 42052


The remote web server is affected by multiple vulnerabilities.


According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.14. It is, therefore, potentially affected by multiple vulnerabilities :

- Faulty error handling in the Solaris pollset support could lead to a denial of service. (CVE-2009-2699)

- The 'mod_proxy_ftp' module allows remote attackers to bypass intended access restrictions. (CVE-2009-3095)

- The 'ap_proxy_ftp_handler' function in 'modules/proxy/proxy_ftp.c' in the 'mod_proxy_ftp' module allows remote FTP servers to cause a denial of service. (CVE-2009-3094)

Note that the remote web server may not actually be affected by these vulnerabilities as Nessus did not try to determine whether the affected modules are in use or check for the issues themselves.


Upgrade to Apache version 2.2.14 or later. Alternatively, ensure that the affected modules are not in use.

See Also






Plugin Details

Severity: High

ID: 42052

File Name: apache_2_2_14.nasl

Version: $Revision: 1.29 $

Type: remote

Family: Web Servers

Published: 2009/10/07

Modified: 2018/01/23

Dependencies: 48204

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:ND/RC:C


Base Score: 7.3

Temporal Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:X/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/10/05

Vulnerability Publication Date: 2009/10/05

Reference Information

CVE: CVE-2009-2699, CVE-2009-3094, CVE-2009-3095

BID: 36254, 36260, 36596

OSVDB: 57851, 57882, 58879

Secunia: 36549

CWE: 119, 264