Mandriva Linux Security Advisory : qemu (MDVSA-2009:257)

Medium Nessus Plugin ID 42047


The remote Mandriva Linux host is missing one or more security updates.


Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests, which allows guest host users with root privileges to access arbitrary memory and escape the virtual machine.

The updated packages have been patched to prevent this.


Update the affected dkms-kqemu, qemu and / or qemu-img packages.

Plugin Details

Severity: Medium

ID: 42047

File Name: mandriva_MDVSA-2009-257.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2009/10/07

Modified: 2016/05/17

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.7

Temporal Score: 4.1

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:dkms-kqemu, p-cpe:/a:mandriva:linux:qemu, p-cpe:/a:mandriva:linux:qemu-img, cpe:/o:mandriva:linux:2009.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/10/05

Reference Information

CVE: CVE-2008-0928

BID: 23731

OSVDB: 42983

MDVSA: 2009:257

CWE: 264